jverein (de.willhuhn.util.ApplicationException)

Hier melden JVerein-Benutzer ihre Fehler

Moderator: heiner

Antworten
Akanje
Beiträge: 4
Registriert: Donnerstag 12. September 2019, 17:33
Verein: DHV
Mitglieder: 3700
JVerein-Version: 2.8.18
Betriebssystem: Linux 64

jverein (de.willhuhn.util.ApplicationException)

Beitrag von Akanje » Freitag 13. September 2019, 11:04

Hi,
nach Upgrade Jameica auf 2.8.4 läuft jVerein nicht mehr. Über "Verfügbare Plugins" von www.jverein/updates 2.8.18 versucht in Betrieb zu nehmen, aber Plugin dort ausgegraut und Fehlermeldung:

Jameica: Plugin-Fehler
jverein (de.willhuhn.util.ApplicationException)

Jemand ne Idee, hab mit dieser Fehlermeldung in Forum und Wiki nichts aktuelles gefunden?

Danke & Gruß
Akanje

----------
PS: DB ist mySQL
Dateianhänge
diagnose-2019-09-12.log
(76.19 KiB) 5-mal heruntergeladen

NicoB77
Beiträge: 74
Registriert: Freitag 21. April 2017, 21:14
Verein: Pollingua e.V.
Mitglieder: 50
JVerein-Version: Entwicklerversion
Betriebssystem: Linux

Re: jverein (de.willhuhn.util.ApplicationException)

Beitrag von NicoB77 » Samstag 14. September 2019, 10:50

Hallo Akanje,

es sieht so aus, als würde ein Datenbankupdate versucht, obwohl das bei einem Update von 2.8.17 auf 2.8.18 nicht nötig ist. Kannst Du in der Datenbank in die Tabelle "version" schauen? Dort sollte nur eine Zeile mit den Werten "1, 417" sein.

Viele Grüße
Reinhard

Akanje
Beiträge: 4
Registriert: Donnerstag 12. September 2019, 17:33
Verein: DHV
Mitglieder: 3700
JVerein-Version: 2.8.18
Betriebssystem: Linux 64

Re: jverein (de.willhuhn.util.ApplicationException)

Beitrag von Akanje » Montag 16. September 2019, 10:35

Moin Moin,

da steht 1, 361.

Was mir zuletzt noch aufgefallen ist: der Ordner "cfg" wurde nicht im Programm-Verzeichnis sondern im Nutzerverzeichnis "jameicaconfig" angelegt, könnte dadurch beim Update was durcheinander gekommen sein?

Herzlichen Gruß
Akanje

Akanje
Beiträge: 4
Registriert: Donnerstag 12. September 2019, 17:33
Verein: DHV
Mitglieder: 3700
JVerein-Version: 2.8.18
Betriebssystem: Linux 64

Re: jverein (de.willhuhn.util.ApplicationException)

Beitrag von Akanje » Montag 16. September 2019, 10:43

PS:

Ausgangssituation war:

Jameica 2.6.4
Hibiscus 2.6.20
jVerein 2.8.17

Akanje
Beiträge: 4
Registriert: Donnerstag 12. September 2019, 17:33
Verein: DHV
Mitglieder: 3700
JVerein-Version: 2.8.18
Betriebssystem: Linux 64

Re: jverein (de.willhuhn.util.ApplicationException)

Beitrag von Akanje » Montag 16. September 2019, 12:59

Hi,
sieht eher so aus, dass unsere DB-Version uralt ist, und der Upgradeversuch scheitert, siehe:

[Mon Sep 16 12:27:55 CEST 2019][ERROR][de.jost_net.JVerein.server.DBSupportMySqlImpl.checkConsistency] Datenbankupdate kann nicht ausgeführt werden.
de.willuhn.util.ApplicationException
at de.jost_net.JVerein.server.JVereinUpdateProvider.<init>(JVereinUpdateProvider.java:100)
at de.jost_net.JVerein.server.DBSupportMySqlImpl.checkConsistency(DBSupportMySqlImpl.java:90)
at de.jost_net.JVerein.server.JVereinDBServiceImpl.checkConsistency(JVereinDBServiceImpl.java:114)
at de.jost_net.JVerein.JVereinPlugin$1.call(JVereinPlugin.java:112)
at de.jost_net.JVerein.JVereinPlugin.call(JVereinPlugin.java:209)
at de.jost_net.JVerein.JVereinPlugin.init(JVereinPlugin.java:105)
at de.willuhn.jameica.plugin.PluginLoader.initPlugin(PluginLoader.java:398)
at de.willuhn.jameica.plugin.PluginLoader.init(PluginLoader.java:243)
at de.willuhn.jameica.services.PluginService.init(PluginService.java:42)
at de.willuhn.boot.BootLoader.resolve(BootLoader.java:139)
at de.willuhn.boot.BootLoader.resolve(BootLoader.java:119)
at de.willuhn.boot.BootLoader.getBootable(BootLoader.java:72)
at de.willuhn.jameica.system.Application.init(Application.java:106)
at de.willuhn.jameica.system.Application.newInstance(Application.java:90)
at de.willuhn.jameica.Main.main(Main.java:78)

[Mon Sep 16 12:27:55 CEST 2019][INFO][de.willuhn.datasource.db.DBServiceImpl.stop] stopping db service
[Mon Sep 16 12:27:55 CEST 2019][INFO][de.willuhn.datasource.db.DBServiceImpl.closeConnection] commit connection
[Mon Sep 16 12:27:55 CEST 2019][INFO][de.willuhn.datasource.db.DBServiceImpl.closeConnection] closing connection
[Mon Sep 16 12:27:55 CEST 2019][INFO][de.willuhn.datasource.db.DBServiceImpl.closeConnection] connection closed
[Mon Sep 16 12:27:55 CEST 2019][INFO][de.willuhn.datasource.db.DBServiceImpl.stop] db service stopped [1 connection(s) closed]
[Mon Sep 16 12:27:55 CEST 2019][ERROR][de.willuhn.jameica.plugin.PluginLoader.init] unable to init plugin jverein: de.willuhn.util.ApplicationException

NicoB77
Beiträge: 74
Registriert: Freitag 21. April 2017, 21:14
Verein: Pollingua e.V.
Mitglieder: 50
JVerein-Version: Entwicklerversion
Betriebssystem: Linux

Re: jverein (de.willhuhn.util.ApplicationException)

Beitrag von NicoB77 » Montag 16. September 2019, 21:00

Genau, der Upgradeversuch scheitert. Die Datenbank ist korrupt: laut Tabelle sollte es Version 361 sein. In Version 362 wurde die Spalte "autobuchunguebernahme" zu der Tabelle "einstellung" hinzugefügt (das war 2014). Aber diese Spalte gibt es in Deiner Datenbank schon, die Versionsnummer kann also nicht stimmen. Die Datenbankversion in 2.8.17 ist 417, und 2.8.18 ändert die Datenbank nicht. Deine Datenbank sollte auch mit Deiner alten Jameica/Jverein-Installation nicht funktionieren. Hast Du noch ein Backup vor dem Upgrade? Und funktioniert das mit 2.8.17? Dann sollte es mit 2.8.18 keine Probleme geben. Ansonsten könntest Du versuchen, die Datenbankversion in der Tabelle auf 417 zu setzen. Mit ein bisschen Glück stimmt nur die Versionsnummer nicht.

Antworten