Mailversand via 1und1

Hier melden JVerein-Benutzer ihre Fehler

Moderator: heiner

Antworten
zuffi
Beiträge: 4
Registriert: Sonntag 9. November 2014, 19:44
Verein: Männergesangverein Dachsbach
Mitglieder: 58
JVerein-Version: 2.8.19
Betriebssystem: Kubuntu

Mailversand via 1und1

Beitrag von zuffi »

Hallo zusammen,

mir ist gerade aufgefallen, dass ich keine Mails über meinen 1und1-Account verschicken kann. Ich kann aber nicht genau sagen, weshalb, da beim Versand selbst keine Fehlermeldung kommt, und die Nachricht in JVerein auch einen Versandzeitpunkt anzeigt.

Ich habe die Vermutung, es könnte an der Einstellung "Authentifizierungsmethode" liegen.

Lt. 1und1-Vorgabe müssen folgende Einstellungen verwendet werden:

Server: smtp.1und1.de
Port 465
Verbindungssicherheit: SSL/TLS
Authentifizierungsmethode "Passwort, normal"

Das kann ich in JVerein alles übernehmen, außer den Punkt Authentifizierungsmethode. Ich weiß, dass es in Thunderbird nicht funktioniert hat, als ich "Passwort, verschlüsselt" ausgewählt hatte. Kann es sein, dass JVerein hier eine Verschlüsselung drüberlaufen läßt?

Oder gibt's sonst noch eine Möglichkeit, woran es liegen könnte?
Die Haken bei SSL und StartTLS hab ich schon in verschwiedenen Varianten gesetzt, Port auch zwischen 465 und 587 gewechselt... es kommt halt leider gar keine Meldung beim Mailversand, weder positiv noch negativ.

Vielen Dank im Voraus
Sebastian
Benutzeravatar
hibiscus
Beiträge: 120
Registriert: Donnerstag 31. Mai 2018, 08:55

Re: Mailversand via 1und1

Beitrag von hibiscus »

Port 465 wird für SSL/TLS verwendet. Du musst in JVerein also "SSL" auswählen und nicht "STARTTLS". STARTTLS wird typischerweise direkt auf Port 25 verwendet. Hierbei startet die Kommunikation erst unverschlüsselt und dann schalten die Kommunikationspartner während der Sitzung über das Kommando "STARTTLS" auf SSL-Verschlüsselung auf dem eigentlich für Plaintext gedachten Port um.

JVerein kann keine verschlüsselte Passwort-Übertragung. Es ist also per Default "Passwort, normal".

Du könntest mal in der "jameica.log" schauen - vielleicht findet sich da noch etwas.
zuffi
Beiträge: 4
Registriert: Sonntag 9. November 2014, 19:44
Verein: Männergesangverein Dachsbach
Mitglieder: 58
JVerein-Version: 2.8.19
Betriebssystem: Kubuntu

Re: Mailversand via 1und1

Beitrag von zuffi »

jameica.log sagt folgendes:

Code: Alles auswählen

java.lang.NoClassDefFoundError: bsh/EvalError
        at de.jost_net.JVerein.Variable.MitgliedMap.getMap(MitgliedMap.java:344)
        at de.jost_net.JVerein.Variable.MitgliedMap.getMap(MitgliedMap.java:58)
        at de.jost_net.JVerein.gui.control.MailControl.getVariables(MailControl.java:529)
        at de.jost_net.JVerein.gui.control.MailControl$EvalMail.<init>(MailControl.java:634)
        at de.jost_net.JVerein.gui.control.MailControl$4.run(MailControl.java:465)
        at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1107)
Caused by: java.lang.ClassNotFoundException: bsh.EvalError
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:445)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:592)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:525)
        ... 6 more
Benutzeravatar
hibiscus
Beiträge: 120
Registriert: Donnerstag 31. Mai 2018, 08:55

Re: Mailversand via 1und1

Beitrag von hibiscus »

Kannst du mal bitte einen größeren Ausschnitt aus dem Log posten?
zuffi
Beiträge: 4
Registriert: Sonntag 9. November 2014, 19:44
Verein: Männergesangverein Dachsbach
Mitglieder: 58
JVerein-Version: 2.8.19
Betriebssystem: Kubuntu

Re: Mailversand via 1und1

Beitrag von zuffi »

Hallo,

sorry für die späte Antwort, hatte deine Nachricht im Forum tatsächlich übersehen.

Ich hänge mal das komplette Log von gerade eben ran - JVerein gestartet, Mail aufgerufen, Testmail "speichern & neu versenden", abgewartet, bis der grüne Balken weg war, JVerein beendet.
es ist also nichts im Log, was nichts mit dem Mailversand zu tun hat.

Vielen Dank!

Log als Link - da ich keine Anhänge anlegen darf: https://nextcloud.owl-it.eu/index.php/s/Cr9L9wy7Be7eq3R
Benutzeravatar
hibiscus
Beiträge: 120
Registriert: Donnerstag 31. Mai 2018, 08:55

Re: Mailversand via 1und1

Beitrag von hibiscus »

Das NextCloud hat dir bei der Synchronisierung scheinbar dein JVerein kaputt gemacht. Laut Log wird beim Starten in /home/zuffi/Nextcloud.owl-it.eu/.jameica/plugins/jverein/lib/ nur eine einzige JAR-Datei gefunden ("itext-hyph-xml.jar"). Wenn du aber mal https://github.com/openjverein/jverein/ ... 2.8.19.zip herunterlädst, siehst du, dass da noch eine ganze Menge mehr Dateien liegen. Das passt auch zu der Fehlermeldung.

Ich würde aber davon abraten, jetzt einfach nur die fehlenden Dateien aus der ZIP-Datei dort abzuspeichern, weil unklar ist, ob und welche Dateien der NextCloud-Sync-Client noch so alles verschwinden lassen hat.

Deswegen sage ich auch immer wieder: Jameica-Homebereich nicht auf einem per Dropbox & Co. synchronisiertem Ordner ablegen (siehe auch https://www.willuhn.de/wiki/doku.php?id ... nis_nutzen). Oder zumindest sicherstellen, dass keine Synchronisierung stattfindet, wenn das Programm läuft.
zuffi
Beiträge: 4
Registriert: Sonntag 9. November 2014, 19:44
Verein: Männergesangverein Dachsbach
Mitglieder: 58
JVerein-Version: 2.8.19
Betriebssystem: Kubuntu

Re: Mailversand via 1und1

Beitrag von zuffi »

Hallo,

vielen Dank für deine tiefe Analyse des Problems.

Ich hatte, als ich noch Windows genutzt hatte, kein einziges Mal ein Problem damit, die Benutzerdaten auf einem Cloud-Ordner liegen zu haben. Aber das kann auch einfach Glück gewesen sein.
Unter Linux ging's jetzt leider schief.

Ich werde versuchen, JVerein / Jameica neu aufzusetzen und die anscheinend vollständig vorhandenen Benutzerdaten dorthin zu übernehmen. Dann halt "leider" ohne die automatische Sicherung in der Cloud, dafür aber stabiler Umgebung.

Nochmal Danke für die Hilfe!
Sebastian
Antworten